Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4873

Summary: pump doesn't supply hostname to server when renewing lease
Product: [Retired] Red Hat Linux Reporter: jar
Component: pumpAssignee: Erik Troan <ewt>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: jar, steve
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 15:52:42 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jar 1999-09-03 01:14:39 UTC
If pump is started with '-h hostname' it does not supply
the hostname to the server when renewing its lease.

I've had to switch to dhcpcd, which works.  It also:

1. Observes the lease timeouts supplied the server.
2. Tries to get the same IP address on a reboot.

Perhaps you could add these (good) features to pump.

thanks,
john

Comment 1 Michael K. Johnson 1999-09-25 05:13:59 UTC
Just checking, you are running pump-0.7.0, right?

Comment 2 Erik Troan 2000-02-03 15:52:59 UTC
*** This bug has been marked as a duplicate of 7486 ***