Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4806

Summary: rpcgen generates garbage
Product: [Retired] Red Hat Linux Reporter: ftaylor
Component: glibcAssignee: Cristian Gafton <gafton>
Status: CLOSED WORKSFORME QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: ftaylor
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-23 03:21:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ftaylor 1999-08-31 17:08:53 UTC
rpcgen -C -M -N -l foo.x -o foo_clnt.c

generates an uncompilable c file with syntax errors

Same file works fine on Solaris 2.6

If you cannot duplicate this, I can send you test data

Comment 1 Jeff Johnson 1999-08-31 17:54:59 UTC
Please send test data. Note that the rpcgen on solaris has different
syntax because of the dynamic port binding etc.

Comment 2 Jeff Johnson 1999-08-31 17:57:59 UTC
*** Bug 4807 has been marked as a duplicate of this bug. ***

the header file generated with:

rpcgen -C -M -N -h cc.x -o cc.h

contains function definitions that are inconsistent with

rpcgen -C -M -N -c cc.x -o cc_xdr.c

functions that take 'pointer to foo' as an argument
in the .c file are defined in the .h file as taking 'foo'
as an argument

Same stuff works well on Solaris 2.x, and has for years

I can send a sample if necessary.


------- Additional Comments From jbj@redhat.com  08/31/99 13:56 -------
Please send sample. I'm going to coalesce these two problems.

Comment 3 Cristian Gafton 1999-09-23 03:21:59 UTC
closed dues to lack of feedback, Please reopen if still have test
data.