Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4776

Summary: Quantity of syslogs from dhcpd drives me insane
Product: [Retired] Red Hat Linux Reporter: Graham Mainwaring <graham>
Component: dhcpAssignee: Erik Troan <ewt>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 6.0CC: graham
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://www.mhn.org/~graham/dhcpd
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-15 21:39:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Graham Mainwaring 1999-08-30 06:18:07 UTC
As the number of DHCP clients served by a dhcpd instance
increases, the size of the syslog tends towards infinity,
since every single client request is logged. This might be
useful for debugging purposes, but it needs to be possible
to turn it off. I have patched dhcpd for this purpose and
have run it on my system for a couple days, but it has
received no wider testing than that. See the referenced URL.

I would like to suggest that the reduced logging mode be
made the default, as it is for all other packages. Imagine
if httpd or named were to try to log each and every
transaction they perform with a client...

Comment 1 Graham Mainwaring 1999-09-08 05:31:59 UTC
I entered a URL into the URL field, but it doesn't seem to show up in
the bug listing. The referenced URL was meant to be
http://www.mhn.org/~graham/linux/dhcpd.html.

Comment 2 Erik Troan 2000-02-15 21:39:59 UTC
This patch should be sent to the dhcpd maintainers at ISC. If they accept
it, we'll certainly change Red Hat to use the new option by default. Please let
us know what happens.