Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4713

Summary: file f771 in wrong place
Product: [Retired] Red Hat Linux Reporter: jgflemin
Component: fort77Assignee: David Lawrence <dkl>
Status: CLOSED WONTFIX QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-30 02:20:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jgflemin 1999-08-26 01:16:54 UTC
I am doing some Fortran 77 stuff on Red Hat Linux 6.0. gcc
wouldn't compile my f77 code and gave me the error that it
couldn't find f771 to exec it. I found the file in
/usr/lib/gcc-lib/i486-linux/2.7.2.3. Once I copied f771 from
there to /usr/bin, the problem was solved. (More
specifically, I encountered the problem while compiling a
numerical analysis package named PETSc. More info on this
from http://www-fp.mcs.anl.gov/petsc/

Comment 1 Cristian Gafton 1999-08-30 02:20:59 UTC
Red Hat Linux 6.0 and later does not ship with fort77 anymore. You
will need to recompile that package from the source rpm (or use the
one in powertools) to get it woring right

You might also use the g77 compiler that comes with egcs in Red Hat
Linux 6.0