Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4699

Summary: mkswap breaks on sparc64...
Product: [Retired] Red Hat Linux Reporter: pjones
Component: util-linuxAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: jbj, pjones
Target Milestone: ---   
Target Release: ---   
Hardware: sparc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-25 03:22:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description pjones 1999-08-25 06:20:28 UTC
its built in a sparc32 environment where PAGE_SIZE is 4096;
the signature and such go to the wrong places, and the
sparc64 kernel looks at PAGE_SIZE-10 for "SWAP-SPACE"; its
at 4086 instead of 8182;  this breaks.

------- Additional Comments From   08/25/99 10:13 -------
This looks like its fixed in the current tree, but an errata _should_
be released.