Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4646

Summary: Soundblaster AWE 64 doesn't work (and solution!)
Product: [Retired] Red Hat Linux Reporter: kumar1
Component: isapnptoolsAssignee: Bill Nottingham <notting>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-24 14:37:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description kumar1 1999-08-22 05:46:11 UTC
The problem I observed is that running "sndconfig" to
configure the soundblaster didn't finish properly. It would
play the linux.au sample properly but choke on the sample
midi file. Canceling and rebooting resulted in sound
initilization failures.

The root cause seems to be that pnpdump doesn't recognize
all the io ports for the Soundblaster wavetable device. In
the kernel source documentation in file
/usr/src/linux/Documentation/sound/AWE32 it shows how to
resolve this by modifying the resulting /etc/isapnp.conf
file.

> Then WaveTable goes. For some reason Plug-n-Play detects
only one I/O port,but the wavetable needs THREE! My working
string is:

> "(CONFIGURE CTL044/1132685 (LD 2 (IO 0 (BASE 0x0620))
> (IO 1 (BASE 0x0A20)) (IO 2 (BASE 0x0E20)) (ACT Y) ))"

> Resources 0x0620, 0x0A20 and 0x0E20 should work. Other
on-board devices: Gameport and StereoEnhance are not
required to be inited.

So in short, I run "sndconfig" as normal, then exit on
failure and edit the /etc/isapnp.conf file as above. Then on
reboot everything works great.

Also, from browsing the isapnptools homepage, I think this
problem is a bug in pnpdump as there was a patch there which
seems related to this problem. However I have not tried
recompliling isapnptools yet as the current solution seems
to work for me.

Comment 1 Bill Nottingham 1999-08-23 16:12:59 UTC
sndconfig should be doing that automatically ; it does it on
all the AWE cards we have.

What does the output of 'pnpdump' say on your system? Perhaps
the card's description isn't something that's recognized as
an AWE card...

Comment 2 Bill Nottingham 1999-08-24 14:37:59 UTC
OK, it didn't recognized the AWE line because it didn't specify
0x620 as the IO port... fixed in sndconfig-0.34-6, which will be
in the next Raw Hide release.