Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 463062

Summary: build fails after undocumented incompatible changes to RPM
Product: [Fedora] Fedora Reporter: Ville Skytt√§ <ville.skytta>
Component: lvm2Assignee: Alasdair Kergon <agk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: agk, bmarzins, bmr, dwysocha, mbroz, prockai
Target Milestone: ---Keywords: Patch, Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-07 20:20:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 463452    
Attachments:
Description Flags
Fix Patch0:/%patch mismatch none

Description Ville Skyttä 2008-09-21 09:38:05 UTC
Created attachment 317312 [details]
Fix Patch0:/%patch mismatch

This package was identified as one that was bit by a bug in Rawhide rpm:
https://www.redhat.com/archives/fedora-devel-list/2008-September/msg00375.html

The rpm bug has been fixed, so currently this is "only" a FTBFS bug for this package - no builds with the broken rpm have apparently been done or tagged for F-10.

Fix attached, I was not able to commit it myself due to CVS ACL restrictions.

Comment 1 Alasdair Kergon 2008-09-21 15:26:40 UTC
(I'll commit, with a comment explaining it's due to a change in the spec file definition.)

Comment 2 Alasdair Kergon 2008-09-23 22:52:57 UTC
Applied - although it's trivial, rebuild submitted as there's a reasonable chance we won't be building again before the next freeze.  (2.02.40 needs to see more testing before I'll know if it's good enough for Fedora at this stage of the release cycle.)

Comment 3 Alasdair Kergon 2008-09-24 00:59:24 UTC
Well the rebuild fails - it looks like someone changed something to do with exec_prefix too so various files are getting placed in the wrong directories - we even have something looking in /usr/usr now!

...moans about the lack of any follow-up announcement to fedora-devel-announce about stuff like this...

Comment 4 Alasdair Kergon 2008-10-07 20:20:49 UTC
They seem to have changed the way exec_prefix is expanded: our spec file changes this but the new rpm code must expand other macros that use exec_prefix too soon - so our revised value is not taken into account and the default gets used.

After much experimentation, I have applied a workaround, which involves overriding the values of the other macros too and the build has now succeeded.