Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4585

Summary: PPP resets hostname, disabling X windows
Product: [Retired] Red Hat Linux Reporter: bashford
Component: pppAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: bashford
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.scripps.edu/bashford
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-08-18 14:55:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description bashford 1999-08-18 10:13:12 UTC
My only connection to the net from my home linux box is
PPP with dynamic IP addressing.  I configured Red Hat 5.2
as standalone, then added my PPP following the information
in the installation guide.  While logged in with an X
windows session, I can use usernet to connect to my ISP,
and the network connection is fine.

However, once the network connection is made, X windows
refuses permission to open any new windows.  This seems to
be because the scripts in /etc/config/network-scripts
have changed my hostname from localhost.localdomain to
something like PPPuser121.scripps.edu, where PPPuser121
is my ISP's idea of my hostname (different on each login)
and scripps.edu is my ISP's domain.

To get out of this jam, I can su to root and do
"hostname localhost.localdomain" and everthing is fine.

Shouldn't the PPP scripts refrain from messing with the
hostname?

Comment 1 Bill Nottingham 1999-08-18 14:55:59 UTC
This is fixed in the initscripts that ship with 6.0