Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 4572

Summary: pump should save state
Product: [Retired] Red Hat Linux Reporter: cmoore
Component: pumpAssignee: Elliot Lee <sopwith>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: redhat
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-07-16 13:40:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description cmoore 1999-08-17 14:15:05 UTC
Hello,

I was recently forced to reboot my RH6.0 system during what
turned out to be a period when the local Roadrunner DHCP
server was down.  At that point I couldn't get Linux back up
again with network services and I had to wait about eight
hours for the cable folks to fix their machine. (pump
0.7.0-1)

My machine is dual-boot with Windows 98 and during this
time, W98 worked perfectly.  I suspect, therefore, that W98
has cached the DHCP information and as long as the lease
hasn't expired they go ahead and use it even if the DHCP
server is down.

I suggest that this behavior would be the right thing for
pump.  Barring that, a way to recall the last DHCP
information and force its use would have saved several hours
of frustration.


Thanks,

Christopher Moore
cmoore@cfa.harvard.edu

Comment 1 Elliot Lee 2001-07-16 20:07:42 UTC
The requested behaviour can cause problems.

e.g. Certain Somebody brings their laptop to work from home, boots Windows up,
and gets LARTed by sysadmins shortly thereafter because the laptop is using its
home-acquired DHCP address on the corporate network.

Needless to say, I was not pleased with the Windows behaviour, and not only does
the present pump behaviour prevent this problem, it is also much more "correct"
(you're not supposed to use an IP without a lease for it).

So, closing this very old bug.