Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 456480

Summary: condor_status -run -format vs condor_q -run -format
Product: Red Hat Enterprise MRG Reporter: Matthew Farrellee <matt>
Component: gridAssignee: Matthew Farrellee <matt>
Status: CLOSED WONTFIX QA Contact: MRG Quality Engineering <mrgqe-bugs>
Severity: low Docs Contact:
Priority: low    
Version: 1.0CC: matt, mkudlej
Target Milestone: Next VersionKeywords: Reopened
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-19 16:58:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matthew Farrellee 2008-07-24 00:56:05 UTC
"condor_status -run -format ..." works as you might expect, it prints out your
special format for all machines with running jobs. Great.

"condor_q -run -format ..." prints out a mixture of "condor_q -run" output and
"condor_q -constraint 'JobStatus==2' -format ..." output. Not great.

Is this intended, or should it be fixed? There is a clear workaround, use
"condor_q -constraint 'JobStatus==2' -format ...", but that's onerous. This also
happens with -hold, -goodput, and -io.