Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 456125

Summary: PackageKit displays update notifications when update is impossible
Product: [Fedora] Fedora Reporter: Stephen Warren <swarren>
Component: PackageKitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: lmacken, richard
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-27 10:12:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Stephen Warren 2008-07-21 16:44:29 UTC
F9 currently has a dependency issue, so updating is impossible for me (this
seems to be happening a lot in F9...)

PackageKit will display that updates are available, but fail due to the
dependency issues.

I propose that PackageKit shouldn't even tell me that updates are available when
they can't be installed. It should do this by depsolving after it's found new
updates.

Perhaps hiding the facts that updates are available would be a bad thing though;
at the very least, PackageKit should display a different popup when it tells me
that updates are available (so I know its not worth trying to update), and also
display some warning on the screen where I would click "apply updates" that its
not worth doing so.

For bonus points, PackageKit should try and work out some way of installing a
maximal subset of available updates, so the dependency issues don't block all
other updates.

Comment 1 Robin Norwood 2008-07-21 16:56:55 UTC
Dependencies in a single repo just shouldn't happen - we should fix the package
process in Fedora to put a stop to those issues.

That said, it's probably useful to at least improve the messaging from PK when
dep issues do occur.

Comment 2 Richard Hughes 2008-07-27 10:12:18 UTC
PackageKit can't do dummy transactions, so Robin is right in saying that this
isn't a PackageKit bug. The F9 updates repo should always be updateable.

PackageKit does enable the yum auto-skip-failed-deps code, but it appears the
yum code doesn't work very well, as it's never worked for me.