Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455974

Summary: Unpackaged directory /usr/share/pygobject/2.0
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: pygobject2Assignee: Matthew Barnes <mbarnes>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: rawhideKeywords: EasyFix, Patch
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-20 22:08:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Robert Scheck 2008-07-19 15:28:03 UTC
Description of problem:
The directory /usr/share/pygobject/2.0 is unpackaged.

Version-Release number of selected component (if applicable):
pygobject2-2.15.1-1

How reproducible:
rpm -qf /usr/share/pygobject/2.0

Actual results:
Unpackaged directory /usr/share/pygobject/2.0

Expected results:
Packaged directory /usr/share/pygobject/2.0

Additional info:
The directory /usr/share/pygobject/2.0 should be owned by pygobject2-codegen 
package, because pygobject2-codegen can be installed without -devel. And if
installing the pygobject2-devel package, the pygobject2-codegen package seems
to be anyway required.

I'm proposing the following patch or better for the next build of the package:
--- pygobject2.spec       2008-07-16 16:06:53.000000000 +0200
+++ pygobject2.spec.rsc   2008-07-19 17:24:25.000000000 +0200
@@ -90,6 +90,7 @@
 %defattr(755, root, root, 755)
 %{_bindir}/pygobject-codegen-2.0
 %defattr(644, root, root, 755)
+%dir %{_datadir}/pygobject/2.0
 %{_datadir}/pygobject/2.0/codegen

 %files devel

Comment 1 Matthew Barnes 2008-07-20 22:08:13 UTC
Thanks Robert.  Fixed in pygobject2-2.15.1-2.fc10.