Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455935

Summary: User.get() should return group information additionally
Product: [Community] Bugzilla Reporter: David Lawrence <dkl>
Component: WebServiceAssignee: Kevin Baker <kbaker>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 3.6CC: ineilsen, kbaker, sgreen
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-19 05:40:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Lawrence 2008-07-18 21:28:51 UTC
Description of problem:
Currently User.get() returns simple information, id, login, real name, email
enabled, etc. Certain third party applications use Bugzilla for authentication
and cache the group information locally instead of calling the XMLRPC methods
each time. We will need that eventually for them to port over to the 3.x API.

Currently they can use bugzilla.userInfo() to accomplish this til then.

Comment 1 David Lawrence 2010-01-15 17:33:43 UTC
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.

Comment 2 David Lawrence 2010-08-25 21:42:13 UTC
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team

Comment 5 Simon Green 2012-06-19 05:40:04 UTC
(In reply to comment #0)
> Description of problem:
> Currently User.get() returns simple information, id, login, real name, email
> enabled, etc. Certain third party applications use Bugzilla for
> authentication
> and cache the group information locally instead of calling the XMLRPC methods
> each time. We will need that eventually for them to port over to the 3.x API.
> 
> Currently they can use bugzilla.userInfo() to accomplish this til then.

This is live (and has been at least since 3.6 went live).

  -- simon