Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455738

Summary: Unfilled progress bar
Product: [Fedora] Fedora Reporter: Pierre-YvesChibon <pingou>
Component: gtk-nodoka-engineAssignee: Martin Sourada <martin.sourada>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 0.7.1-1.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-01 01:46:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot to explain none

Description Pierre-YvesChibon 2008-07-17 14:21:02 UTC
Description of problem:
Using guake, going into the preferences there is a bar that helps to chose the
size of the windows desired.

If I put the bar to 100% it does not do what it should.
(see the picture for a better understanding :) )

Version-Release number of selected component (if applicable):
$ rpm -q nodoka-theme-gnome
nodoka-theme-gnome-0.3.90-1.fc9.noarch


How reproducible:
always

Steps to Reproduce:
1. Start guake
2. Goes to the preferences
3. Put the window size to 100%
  
Actual results:
The bar is not entirely filled

Expected results:
It should be :)

Comment 1 Pierre-YvesChibon 2008-07-17 14:21:02 UTC
Created attachment 312052 [details]
Screenshot to explain

Comment 2 Martin Sourada 2008-07-17 14:53:46 UTC
This problem is inherited from the murrine engine we forked initially, it's not
ProgressBar but most likely Scale and the correct component is gtk-engine-nodoka
(nodoka-theme-gnome contains only gnome meta-theme and metacity theme). Since it
works with Clearlooks and Glossy engines, it should be easy to find the root of
the problem by comparing the code. Thanks for the report :-)

Comment 3 Martin Sourada 2008-07-17 15:48:27 UTC
Just found the problem. Guake sets page_size for the Adjustment inside Scales to
10, I don't know why...

"The page size of the adjustment. Note that the page-size is irrelevant and
should be set to zero if the adjustment is used for a simple scalar value, e.g.
in a GtkSpinButton."

Because 
"Note that values will be restricted by upper - page-size if the page-size
property is nonzero."
and because we didn't take page-size into account, it resulted in this behaviour
you described. I've prepared a patch that fixes it and will commit it to git
soonish. I'll fix it in Fedora together with another two or three bugfixes,
IIRC, as a new release, probably tonight or tomorrow.

Comment 4 Fedora Update System 2008-07-22 21:33:53 UTC
gtk-nodoka-engine-0.7.1-1.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-07-24 02:12:27 UTC
gtk-nodoka-engine-0.7.1-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gtk-nodoka-engine'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6688

Comment 6 Fedora Update System 2008-08-01 01:46:45 UTC
gtk-nodoka-engine-0.7.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.