Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455456

Summary: nfs4 mounted file system begining with "ram" seen as ramfs in gnome
Product: Red Hat Enterprise Linux 5 Reporter: Francois Marabelle <francois.marabelle>
Component: dbusAssignee: Matthias Clasen <mclasen>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.2CC: francois.marabelle, tpelka
Target Milestone: rcFlags: pm-rhel: needinfo? (francois.marabelle)
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2014-06-02 13:03:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Francois Marabelle 2008-07-15 16:04:42 UTC
Description of problem:

When nfs4 mount a disk file system begining with "ram" it's seen as a ramfs 


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. create a directory begining with"ram"
2. mount any nfs4 exported fs on it
3.
  
Actual results:

-seen as a ramfs 
-put an icon on gnome desktop

using dbus-monitor, dbus passed the fs with:
string "gnome-dev-memory"


Expected results:

no icon on gnome desktop
dbus should pass the fs with:
string "gnome-dev-harddisk"



Additional info:

Comment 1 Steve Dickson 2008-07-17 10:02:45 UTC
I'm not sure I see why this is an NFS problem?

Comment 2 Francois Marabelle 2008-07-17 10:18:16 UTC
(In reply to comment #1)
> I'm not sure I see why this is an NFS problem?

Because if I mount the fs using nfs3, there's no problem. So I suppose nfs4 is
involved somewhere.

Comment 3 Jeff Layton 2008-07-29 12:52:23 UTC
Moving this to dbus based on initial comment. If it turns out to be a problem
with nfs-utils, please reassign it to me.

Comment 5 RHEL Product and Program Management 2014-03-07 12:40:31 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 6 RHEL Product and Program Management 2014-06-02 13:03:41 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).