Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455397

Summary: Missing org.apache.batik.i18n.LocalizableSupport
Product: [Fedora] Fedora Reporter: Stefan Neufeind <redhat>
Component: batikAssignee: Lillian Angel <langel>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: kwizart, mricher, ppp5
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-28 15:47:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stefan Neufeind 2008-07-15 11:46:43 UTC
I'm getting this on running a tool:

java.lang.NoClassDefFoundError: org.apache.batik.i18n.LocalizableSupport

Am I missing a sub-package of batik? Do we miss a "useful" package for batik in
the Fedora-repo?

Comment 1 Lillian Angel 2008-07-15 17:54:41 UTC
I am not sure how to reproduce this, can you give me more information?

Comment 2 Stefan Neufeind 2008-07-15 18:06:58 UTC
Part of an OpenStreetMap-renderer uses batik-rasterizer to render SVG into PNG.
Thats where the error about a missing class appears. And since I didn't find it
in any package nor any "batik-i18n"-package or so I wonder if this might be some
yet unpackaged part of batik or so ...

Comment 3 Nicolas Chauvet (kwizart) 2008-11-24 22:04:09 UTC
org.apache.batik.i18n.LocalizableSupport is available in the batik-all.jar
-all means all batik "libraries" ,which include batik-rasterizer. It is also possible to build them separately. Maybe you need to set some CLASSPATH ?!

Comment 4 Piotr Piotrowski 2008-11-27 20:54:49 UTC
The same error exists in Fedora 10. When I use the script /usr/bin/rasterizer from batik-rasterizer.rpm the same error occurs. I have investigated it and found that when I add some missing jars to the BASE_JARS variable in the script, rendering to PNG works. It might be important that I use Sun's JRE and I do not use alternatives.

More over to be able to render to PDF FOP is needed that is not in batik-rasterizer.rpm dependencies.

Comment 5 Lillian Angel 2008-11-28 15:47:08 UTC
Thanks. fixed, will appear in rawhide and updates soon.

Comment 6 Fedora Update System 2008-11-28 16:50:44 UTC
batik-1.7-0.5 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/batik-1.7-0.5

Comment 7 Fedora Update System 2008-11-28 16:51:38 UTC
batik-1.7-0.6 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/batik-1.7-0.6

Comment 8 Fedora Update System 2008-12-03 01:20:31 UTC
batik-1.7-0.5 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-12-03 01:28:37 UTC
batik-1.7-0.6 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 R. Michael Richer 2010-04-23 14:24:09 UTC
(In reply to comment #9)
> batik-1.7-0.6 has been pushed to the Fedora 10 stable repository.  If problems
> still persist, please make note of it in this bug report.    

Regression in FC12.

batik-rasterizer-1.7-6.fc12.noarch once again is missing the i18n stuff.