Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455245

Summary: CDROM test in HTS 5.2-16 didn’t finish correct
Product: Red Hat Hardware Certification Program Reporter: Sirius Rayner-Karlsson <tak>
Component: Test Suite (tests)Assignee: YangKun <ykun>
Status: CLOSED ERRATA QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5CC: asheltz, balkov, mike.carvin, ndai, rlandry, tak, tao, ykun
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: hts-5.2-19 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-11-12 19:24:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sirius Rayner-Karlsson 2008-07-14 12:46:15 UTC
Customer Writes:

I’ve downloaded the following HTS-5.2-16 versions from RHN:

RHEL5 ( 64 bit )
 hts-5.2-16.el4.noarch.rpm (158,655 bytes)  Build Date: 2008-06-12 01:37:15

RHEL4 (64 bit)
 hts-5.2-16.el5.noarch.rpm (322,232 bytes)  Build Date: 2008-06-12 01:40:28

Inside the CROM test I got following error:
 File „./“, line 88, in handleEject
   self.prompt(„n Please close the drive tray manually then press ENTER to
continue.“ % deviceFile)
 TypeError: not all arguments converted during string formatting
 …finished running ./, exit code=1

 /usr/share/hts/tests/cdrom/  line 88 have to be changed to
   self.prompt(„n Please close the drive tray %s manually then press ENTER to
continue.“ % deviceFile)

After this change the test works fine.

I can see this error inside for RHEL5 (64 bit) and RHEL4 (64 bit) but I
guess that the 32 bit versions are including the same error.

Comment 1 Sirius Rayner-Karlsson 2008-07-14 12:54:59 UTC
Hi there,

I've filed this BZ as the counterpart of IT#191393. The customer also reports
that in the process of reporting this problem, they found that the e-mail
address "" do not work. I have tried it, and can
confirm that it is non-functional.



Comment 5 Jeremy West 2008-08-18 14:40:22 UTC
*** Bug 459303 has been marked as a duplicate of this bug. ***

Comment 9 Mike Carvin 2008-09-02 17:01:50 UTC
Any idea when HTS 5.2-19 will be available?

Comment 10 YangKun 2008-09-08 07:51:09 UTC
*** Bug 459716 has been marked as a duplicate of this bug. ***

Comment 17 Nicole Dai 2008-10-15 09:15:19 UTC
Verified the bug does not exist in hts-5.2-20.el5 and hts-5.2-20.el4 on RHEL
5 and 4.

Comment 19 errata-xmlrpc 2008-11-12 19:24:38 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.