Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455147

Summary: libgcrypt needs at least version 1.5 of libgpg-error
Product: [Fedora] Fedora Reporter: Noa Resare <noa>
Component: libgcryptAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: jorton, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-14 16:01:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Noa Resare 2008-07-12 19:54:26 UTC
Description of problem:
The symbol gpg_err_code_from_syserror showed up between 1.4 and 1.5 of libgpg-error according to 
the ChangeLog. A small improvement to the libcrypt package would be to add this dependency 
explicitly to the package.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. try to recompile libgcrypt on for example rhel4
Actual results:
compilation fails with missing symbol gpg_err_code_from_syserror

Expected results:

Additional info:

Comment 1 Nalin Dahyabhai 2008-07-14 16:01:41 UTC
Despite the changelog, the function appears to have landed in time for 1.4, as
it's in the F7 package's source tree.  It looks like the requirement on >=1.4 is
correct, so I'm marking this won't-fix.  Please reopen this bug report if I've
missed something.