Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 455022

Summary: Can't access /dev/sr0, /dev/cdrom, /dev/sr1, etc. to write DVD .... Works as root.
Product: [Fedora] Fedora Reporter: Tom London <selinux>
Component: halAssignee: David Zeuthen <davidz>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 10CC: jamundso, joerg.schilling, mclasen, quantumburnz
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-12 16:34:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Tom London 2008-07-11 14:45:27 UTC
Description of problem:
[Sorry if this BZ needs to be re-directed....]

If I try to write to a blank DVD from desktop, I get failure popup/message.

If I try to write to a blank DVD from console via "dvdrecord -v dev=/dev/cdrom
*.iso" or "dvdrecord -v dev=/dev/sr0 *.iso", I get:

[tbl@localhost Downloads]$ dvdrecord -v dev=/dev/cdrom *.iso
dvdrecord: No write mode specified.
dvdrecord: Asuming -tao mode.
dvdrecord: Future versions of wodim may have different drive dependent defaults.
TOC Type: 1 = CD-ROM
dvdrecord: Operation not permitted. Warning: Cannot raise RLIMIT_MEMLOCK
limits.scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
dvdrecord: Permission denied. 
Cannot open SCSI driver!
For possible targets try 'wodim --devices' or 'wodim -scanbus'.
For possible transport specifiers try 'wodim dev=help'.
For IDE/ATAPI devices configuration, see the file README.ATAPI.setup from
the wodim documentation.
[tbl@localhost Downloads]$ 

Works if I run one of the above commands as root.

[tbl@localhost Downloads]$ getfacl /dev/sr0
getfacl: Removing leading '/' from absolute path names
# file: dev/sr0
# owner: root
# group: disk
user::rw-
user:tbl:rw-			#effective:r--
group::r--
mask::r--
other::---

[tbl@localhost Downloads]$ 

Version-Release number of selected component (if applicable):
hal-0.5.11-2.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2008-07-18 00:01:44 UTC
Also works if I 'chmod 666 /dev/sr0' ....

Comment 2 Bug Zapper 2008-11-26 02:32:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Jörg Schilling 2009-02-10 15:22:37 UTC
You are suffering from a problem that is a result from
using a defactive fork instead of original software.
The people behind the defective fork do not like to
admit that root privileges are needed in order to let
cdrecord work correctly. They even removed several related
consistency checks and cause the fork to fail later with 
unklear problems.

Doing a chmod on /dev/ entries is not a solution as it
causes your system to become less secure.

I recommend to get recent original software from:

ftp://ftp.berlios.de/pub/cdrecord/alpha/

make sure to call "make install" as root to get it
installed suid root.

Comment 4 Tom London 2009-02-10 15:34:01 UTC
I'm running rawhide, but there 'getfacl /dev/sr0' now says:

[root@tlondon ~]# getfacl $_
getfacl: Removing leading '/' from absolute path names
# file: dev/sr0
# owner: root
# group: cdrom
user::rw-
user:tbl:rw-
group::rw-
mask::rw-
other::---

[root@tlondon ~]# 

Looks like the "mask" has changed from "r--" to "rw-".

I'm guessing changes with {Policy,Console}Kit or some such.

Comment 5 Jerry Amundson 2009-08-12 14:21:37 UTC
Works for me.
hal-0.5.12-15.20081027git.fc10.i386 (from updates-testing)

Comment 6 Tom London 2009-08-12 14:29:46 UTC
I haven't closed this since I've been running Rawhide (not fc10!), so I couldn't verify that it was fixed for fc10.

I'm willing to close this based on report in comment 5....