Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 454405

Summary: wierd upstream behaviour regarding /usr/bin/net-snmp-config in -devel split package
Product: [Fedora] Fedora Reporter: Rudolf Kastl <che666>
Component: net-snmpAssignee: Jan Safranek <jsafrane>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-24 10:14:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Rudolf Kastl 2008-07-08 10:19:02 UTC
Description of problem:
net-snmp-devel contains /usr/bin/net-snmp-config. everyone knows those "pre
pkgconfig" scripts that take --cflags --libs etc, but in this case the binary is
also there for creating snmp v3 users.
my personal view is that this is some bad upstream behaviour but then again it
boils also down to a packaging bug because having a script to add v3 users into
the -devel package doesent make sense.

Version-Release number of selected component (if applicable):
net-snmp-5.4.1-19.fc10.i386

Comment 1 Jan Safranek 2008-07-24 10:14:57 UTC
I've checked net-snmp-create-v3-user into net-snmp SVN (rev. 17118), it will be
available in next net-snmp release.