Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 454256

Summary: dbxml-perl not built for perl 5.10.0
Product: [Fedora] Fedora Reporter: Paul Howarth <paul>
Component: dbxml-perlAssignee: Milan Z√°zrivec <mzazrivec>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.003-5.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-17 15:28:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 454257    

Description Paul Howarth 2008-07-07 10:08:06 UTC
The F-9 package of dbxml-perl has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0. In order to avoid a repeat of this problem in the future, I
suggest adding the following dependency to the package (which can be found in
virtually all Fedora perl packages):

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

P.S. If (as I think is the case), the package is licensed under the same terms
as perl itself, the license tag should be "GPL+ or Artistic", not "GPL+ or
Artistic 2.0".

Comment 1 Fedora Update System 2008-07-07 16:11:47 UTC
dbxml-perl-2.003-5.fc9 has been submitted as an update for Fedora 9

Comment 2 Fedora Update System 2008-07-09 02:54:44 UTC
dbxml-perl-2.003-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dbxml-perl'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6254

Comment 3 Fedora Update System 2008-07-30 20:01:21 UTC
dbxml-perl-2.003-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Paul Howarth 2008-09-17 15:28:40 UTC
Problem fixed in dbxml-perl-2.003-5.fc9. License tag fixed too :-)