Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 454097

Summary: XML Docbook catalog broken in rawhide
Product: [Fedora] Fedora Reporter: Kjartan Maraas <kmaraas>
Component: sgml-commonAssignee: Ondrej Vasik <ovasik>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: mjg
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-04 16:06:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kjartan Maraas 2008-07-04 15:49:19 UTC
Description of problem:

After a recent rawhide update I started seeing this:

checking if Perl version >= 5.6.0... yes
checking for openjade... /usr/bin/openjade
checking for xsltproc... /opt/tarball-gnome2/bin/xsltproc
checking for XML catalog (/etc/xml/catalog)... found
checking for xmlcatalog... /opt/tarball-gnome2/bin/xmlcatalog
checking for DocBook XML DTD V4.1.2 in XML catalog... not found
configure: error: could not find DocBook XML DTD V4.1.2 in XML catalog
*** error during stage configure of gtk-doc: ########## Error running
./configure --prefix /opt/tarball-gnome2 --libdir '${exec_prefix}/lib' 
--disable-static --disable-gtk-doc   *** [9/182]

From config.log:

configure:21019: result: /opt/tarball-gnome2/bin/xsltproc
configure:21046: checking for XML catalog (/etc/xml/catalog)
configure:21049: result: found
configure:21060: checking for xmlcatalog
configure:21078: found /opt/tarball-gnome2/bin/xmlcatalog
configure:21091: result: /opt/tarball-gnome2/bin/xmlcatalog
configure:21110: checking for DocBook XML DTD V4.1.2 in XML catalog
configure:21113: $XMLCATALOG --noout "$XML_CATALOG_FILE" "-//OASIS//DTD DocBook
XML V4.1.2//EN" >&2
No entry for PUBLIC -//OASIS//DTD DocBook XML V4.1.2//EN
configure:21116: $? = 4
configure:21121: result: not found
configure:21123: error: could not find DocBook XML DTD V4.1.2 in XML catalog


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kjartan Maraas 2008-07-04 16:06:07 UTC
yum reinstall docbook-dtds fixed this. Somehow my docbook catalog got broken
during rawhide updates it seems...that's another bug I guess.

Comment 2 Ondrej Vasik 2008-07-04 16:19:32 UTC
Thanks for report, already had the report before your bugzilla via private
email, problem is in missing config(noreplace) for
/usr/share/sgml/docbook/xmlcatalog. Unfortunately - there was request for
marking those catalog files verify(not md5 size mtime) to silence rpm -V. That
caused modification of xmlcatalog file and file with catalogs was replaced by
empty one.

As is not allowed to use config(noreplace) for files in /usr, I have to move it
in /etc and make an symlink. Unfortunately there is no way how to fix those
broken docbook-dtds - as they are comming from post section of docbook-dtds spec
file. I recommend to force reinstall of docbook-dtds. 

"Troublemaker" file xmlcatalog is marked config(noreplace) in
sgml-common-0.6.3-25.fc10 so it should not happen next time. Sorry, but can't
help more, closing CANTFIX. Although it is hopefully fixed RAWHIDE. Hope you
understand the reasons.

Comment 3 Ondrej Vasik 2008-07-04 16:20:27 UTC
Mid-air colision - but you have now the explanation.

Comment 4 Michael J Gruber 2010-11-25 08:10:37 UTC
This was reported during the release cycle for an EOLed release.

There has been one possibly related report for Fedora 14 on the Git list:

http://permalink.gmane.org/gmane.comp.version-control.git/161909

But the proposed is in the F10 version of sgml-common, so I'm marking this NEXTRELEASE (next relative to the reporter's).