Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453981

Summary: KVM: pvmmu breakage with gcc 4.3.0
Product: [Fedora] Fedora Reporter: Mark McLoughlin <markmc>
Component: kernelAssignee: Mark McLoughlin <markmc>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: clydekunkel7734, kernel-maint, mtosatti, xen-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: kernel-2.6.26-0.115.rc9.git2.fc10 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-08 09:30:04 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark McLoughlin 2008-07-03 16:36:27 UTC
Rawhide (2.6.26-rc) guests running on a rawhide host is broken at the moment,
because of this:

  http://www.mail-archive.com/kvm@vger.kernel.org/msg01023.html

If you set earlyprintk=serial, you just see the guest hang at e.g.:

     0MB HIGHMEM available.
     511MB LOWMEM available.

To fix rawhide, we can either:

  1) Wait for Avi to send a fix to Linus and have the fix pulled in naturally

  2) Take whatever fix Avi accepts into git and backporting 

  3) Just disabling CONFIG_KVM_GUEST for now

Since it's been broken for quite a while, I'm just assuming we'll do (1), but
that doesn't happen soon we should probably just do (3)

Comment 1 Mark McLoughlin 2008-07-07 09:35:06 UTC
Fix went into Linus's tree just after -rc9:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=ca3739327b89bb

Comment 2 Mark McLoughlin 2008-07-07 22:20:54 UTC
*** Bug 449786 has been marked as a duplicate of this bug. ***

Comment 3 Mark McLoughlin 2008-07-08 09:30:04 UTC
Should be fixed now by kernel-2.6.26-0.115.rc9.git2.fc10