Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453923

Summary: munin package should have perl(:MODULE_COMPAT...) dependency
Product: [Fedora] Fedora Reporter: Paul Howarth <paul>
Component: muninAssignee: Kevin Fenzi <kevin>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-12 17:02:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 454257    

Description Paul Howarth 2008-07-03 09:05:59 UTC
The original F-9 package of munin had modules in "perl 5.8.8" paths,
which were not found by F-9's perl 5.10.0. The 1.2.5-5.fc9 update was built
against perl 5.10.0, which resolved the immediate problem.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0. Any package that includes perl modules in the
%{perl_vendorlib} or %{perl_vendorarch} directories (which are versioned by perl
version number) should have the following "Requires" tag added so that such
dependencies are properly flagged in future:

Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

P.S. The perl-HTML-Template dependency in the main package is redundant as RPM
automatically adds a dependency on perl(HTML::Template)

Comment 1 Paul Howarth 2008-07-03 09:21:42 UTC
Changing to Rawhide as F-9 isn't actually broken.

Comment 2 Kevin Fenzi 2008-07-12 17:02:44 UTC
Sounds like a fine idea. 
Change made in rawhide and built. 

Feel free to re-open or file a new bug if you see any issues... 

Thanks for pointing this one out!

Comment 3 Fedora Update System 2008-09-08 21:42:30 UTC
munin-1.2.6-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/munin-1.2.6-3.fc9

Comment 4 Fedora Update System 2008-09-08 21:44:20 UTC
munin-1.2.6-3.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/munin-1.2.6-3.fc8

Comment 5 Fedora Update System 2008-10-01 06:33:11 UTC
munin-1.2.6-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2008-10-01 06:34:39 UTC
munin-1.2.6-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.