Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453881

Summary: yum via proxy
Product: [Fedora] Fedora Reporter: gnazio <gnazio>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: ffesti, james.antill, katzj, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-07 12:31:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description gnazio 2008-07-03 00:25:29 UTC
Description of problem:
Hello, on my laptop I have Fedora8 (still got no time to upgrade).
I use it both at home and at work, where there is an ISA proxy server.
It's not much pratical for me to edit yum.conf to comment/uncomment the proxy
configuration so I prefer to source a script that exports (http)|(ftp)_proxy for
me (with username and password).
This approach always worked, but today the proxy is responding with error 407
trying to run yum update. Wget is working as expected after exporting http_proxy.


Version-Release number of selected component (if applicable):

yum-versionlock-1.1.14-4.fc8                  Sat 14 Jun 2008 04:31:27 PM CEST
yum-utils-1.1.14-4.fc8                        Sat 14 Jun 2008 04:31:26 PM CEST
yum-downloadonly-1.1.14-4.fc8                 Sat 14 Jun 2008 04:31:26 PM CEST
yum-fastestmirror-1.1.14-4.fc8                Sat 14 Jun 2008 04:31:25 PM CEST
yum-updatesd-0.9-1.fc8                        Sat 29 Dec 2007 08:01:35 AM CET
yum-3.2.8-2.fc8                               Sun 23 Dec 2007 12:24:31 AM CET
yum-metadata-parser-1.1.2-1.fc8               Sun 23 Dec 2007 12:24:19 AM CET

How reproducible:


Steps to Reproduce:
1. export http_proxy=http://$PROXY_USER:$PROXY_PASS@$PROXY_HOST:$PROXY_PORT
2. run yum update behind a proxy

  
Actual results:
error 407 from the proxy

Expected results:
yum access the repositories behind a proxy simply exporting http_proxy as
reported for example here
https://fedoraproject.org/wiki/Docs/Drafts/AdministrationGuide/ManagingSoftware/YumProxy
 in "Configuring Proxy Server Access for a Single User" section and without
touching yum.conf

Additional info:

If it could be relevant on the last yum update run done via proxy, the following
packages has been updated (I could provide the full list if needed).
yum-versionlock-1.1.14-4.fc8                  Sat 14 Jun 2008 04:31:27 PM CEST
yum-utils-1.1.14-4.fc8                        Sat 14 Jun 2008 04:31:26 PM CEST
yum-downloadonly-1.1.14-4.fc8                 Sat 14 Jun 2008 04:31:26 PM CEST
yum-fastestmirror-1.1.14-4.fc8                Sat 14 Jun 2008 04:31:25 PM CEST

After that (and before today), 14th, I've only ran yum update at home (no proxy).

Comment 1 gnazio 2008-07-03 23:33:54 UTC
I've tried again today and it's working. No changes has been done since
yesterday, so I can't explain the reason.
So it seems that this bug report could be closed.