Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453879

Summary: packaging issue caused ldconfig messages
Product: [Fedora] Fedora Reporter: Valdis Kletnieks <valdis.kletnieks>
Component: snortAssignee: Dennis Gilmore <dennis>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 10CC: florian.laroche, smooge
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-02-10 21:02:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Valdis Kletnieks 2008-07-03 00:02:03 UTC
Description of problem:
After installing/upgrading snort, subsequent ldconfig runs produce messages:

/sbin/ldconfig: /usr/lib64/snort/dynamicengine/libsf_engine.so.0 is not a
symbolic link
/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_dcerpc_preproc.so.0
is not a symbolic link
/sbin/ldconfig:
/usr/lib64/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.so.0 is not a
symbolic link
/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_ssh_preproc.so.0 is
not a symbolic link
/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_smtp_preproc.so.0 is
not a symbolic link
/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_dns_preproc.so.0 is
not a symbolic link

Version-Release number of selected component (if applicable):
snort-2.8.1-4.fc10.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John Poelstra 2008-10-20 22:42:27 UTC
I cannot reproduce this with latest rawhide version 2.8.1-5.fc10

Can you?

Comment 2 Valdis Kletnieks 2008-10-21 00:52:53 UTC
Yes, it appears fixed in 2.8.1-5.

Comment 3 Bug Zapper 2008-11-26 02:30:17 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Dennis Gilmore 2009-02-10 21:02:45 UTC
reported as fixed.  closing.

Comment 5 Valdis Kletnieks 2009-02-17 18:28:34 UTC
Well, I just installed Rawhide snort-2.8.3.2-1.fc11.x86_64 and the issue seems to have re-appeared:

/sbin/ldconfig: /usr/lib64/snort/dynamicengine/libsf_engine.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_dcerpc_preproc.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_ssl_preproc.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_ssh_preproc.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_smtp_preproc.so.0 is not a symbolic link

/sbin/ldconfig: /usr/lib64/snort/dynamicpreprocessor/libsf_dns_preproc.so.0 is not a symbolic link

Argh.