Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453803

Summary: nfsnobody missing
Product: [Fedora] Fedora Reporter: Robert Story <rs>
Component: nfs-utilsAssignee: Steve Dickson <steved>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: adam
Target Milestone: ---   
Target Release: ---   
Hardware: powerpc   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-01 03:56:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Robert Story 2008-07-02 16:16:46 UTC
Description of problem:
The nfs-utils package fails to create the nfsnobody use

Version-Release number of selected component (if applicable):
nfs-utils-1.1.2-2.fc9

How reproducible:
always

Steps to Reproduce:
1. install nfs-utils on a ppc (32 bit) machine
2.
3.
  
Actual results:
no error, no nfsnobody user

Expected results:
nfsnobody user

Additional info:
The problem is clear in the spec file:

%define all_32bit_archs i386 i686 athlon

This causes a 64bit -2 to be passed to useradd. Trying this on the command line:
# /usr/sbin/useradd -l -c "Anonymous NFS User" -r -s /sbin/nologin -u 4294967294
-d /var/lib/nfs nfsnobody
useradd: invalid numeric argument '4294967294'

The error is hidden because the useradd output is redirected to /dev/null.

Comment 1 Adam Goode 2008-09-01 03:56:26 UTC
Looks like this is fixed in nfs-utils 1.1.2-4.