Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453636

Summary: /var/log created with wrong xattributes.
Product: [Fedora] Fedora Reporter: Bill C. Riemers <briemers>
Component: filesystemAssignee: Ondrej Vasik <ovasik>
Status: CLOSED INSUFFICIENT_DATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: urgent Docs Contact:
Priority: high    
Version: 9CC: pknirsch
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-08-09 19:00:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bill C. Riemers 2008-07-01 16:46:02 UTC
Description of problem:

This is so strange, I went to tail /var/log/messages, and discovered I have no
log files other than /var/log/yum.log.  I am using pretty much a generic Fedora
9 install, with no changes to /etc/rsyslog.conf.   rsyslogd is running, but no
log files are being created.

After I decided to send a HUP to rsysctl, and discovered the problem was
/var/log was created with the wrong xattributes by the Fedora 9 install.

I did 'restorecon -v /var/log && pkill -HUP rsysctld' and now everything is
working fine.

Version-Release number of selected component (if applicable):

filesystem-2.4.13-1.fc9.i386

How reproducible:

I haven't tried.

Steps to Reproduce:
1. Install Fedora 9 with an encrypted root from the install DVD with SELinux in
enforcing mode.
2.
3.
  
Actual results:

/var/log has wrong xattributes.  No messages are logged.

Expected results:

/var/log should have correct attributes.

Additional info:

Comment 1 Bug Zapper 2009-06-10 01:52:20 UTC
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Ondrej Vasik 2009-07-07 12:30:33 UTC
Thanks for report and sorry for late response - just got maintainance of that package. Does the issue still persist? Does it apply for later Fedoras(as F-9 is almost EOL)? Could you, please, provide ls -lZd /var/log before restorecon? Anyway - such thing can't be easily solved in filesystem package itself, I guess it is more for anaconda installer or something like this (as I guess there are no %post scriptlets allowed in filesystem and i can't restorecon (due to dependency loop) in filesystem package).
Changing version to F-10 to prevent autoclosing ...

Comment 3 Ondrej Vasik 2009-08-09 19:00:39 UTC
Closing insufficient data (as reported against EOL F-9 and likely not so urgent as initial report). Feel free to reopen that bugzilla if you still experience that issue with current Fedora.