Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453488

Summary: can't reuse guest name without restarting virt-manager
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: virt-managerAssignee: Daniel Berrange <berrange>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: cdahlin, crobinso, hbrock, markmc, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-03 10:35:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 438944    

Description Jens Petersen 2008-07-01 00:06:27 UTC
Description of problem:
If I install a guest under virt-manager and then delete it and install another
guest under the same name in virt-manager: the console for the new guest refuses
to appear.  Workaround is to quit virt-manager and start it again and voila.

How reproducible:
every time

Steps to Reproduce:
1. install a guest OS (call it "rawhide1")
2. later delete rawhide1 from virt-manager
3. try to reinstall "rawhide1" as a new guest
  
Actual results:
3. Press Finish in install setup does not bring up console window for rawhide1
 (I think it flashes up and then disappears.)  Pressing Finish again and a message
  appears saying it is already running.

Expected results:
3. new console to appear normally

Additional info:
It is annoying having to restart virt-manager for this.

Comment 1 Cole Robinson 2008-12-01 19:44:37 UTC
*** Bug 453009 has been marked as a duplicate of this bug. ***

Comment 2 Jens Petersen 2009-04-01 06:13:36 UTC
I think this may be fixed in 0.6.1 or earlier.

Comment 3 Mark McLoughlin 2009-04-03 10:35:24 UTC
Okay, this was filed against F9, but since it's fixed in rawhide and easy to work around, I'm closing the bug. Thanks Jens.