Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453446

Summary: DKMS ignores DEST_MODULE_LOCATION
Product: [Fedora] Fedora Reporter: Michel Alexandre Salim <michel>
Component: dkmsAssignee: Mario Limonciello <mario_limonciello>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: jcm, linux-bugs, mario_limonciello, matt_domsch, tcallawa
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-15 20:41:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michel Alexandre Salim 2008-06-30 17:57:31 UTC
Description of problem:
DKMS ignores said configuration key, as specified in
/usr/src/$MODULE_NAME-$MODULE_VERSION/dkms.conf

Version-Release number of selected component (if applicable):
2.0.19.1-1

How reproducible:
Always

Steps to Reproduce:
1. Install dkms-ndiswrapper, or any other DKMS package from FreshRPMS. Or roll
your own
2. find /lib/modules -name 'ndiswrapper*'
3. Try uninstalling and reinstalling the module (FreshRPMS sets the quiet flag
so a lot of information is not shown)
  
Actual results:
All kernel modules installed in /lib/modules/$KERNEL_VERSION/extra, rather than
/lib/modules/$KERNEL_VERSION/kernel/... as specified in dkms.conf


Expected results:
DEST_MODULE_LOCATION option honored

Additional info:
For example, this is the dkms.conf for ndiswrapper:

PACKAGE_NAME=ndiswrapper
PACKAGE_VERSION=1.52-1.fc9
MAKE[0]="make KERNEL_LOCATION=${kernel_source_dir}"
CLEAN[0]="make clean"
BUILT_MODULE_NAME[0]=ndiswrapper
DEST_MODULE_LOCATION[0]=/kernel/drivers/net/wireless/ndiswrapper
AUTOINSTALL="YES"

and here is where it ended up:
$ find /lib/modules/2.6.25.6-55.fc9.x86_64/ -name 'ndiswrapper*'
/lib/modules/2.6.25.6-55.fc9.x86_64/extra/ndiswrapper.ko

Comment 1 Matt Domsch 2008-06-30 18:30:44 UTC
I think this is working-as-designed.  As of Fedora 6 and higher, modprobe will 
look in /lib/modules/$kernelver/extra/ for add-on modules by design.  DKMS 
knows this, and overrides the specified DEST_MODULE_LOCATION values specified 
in dkms.conf.

Is this causing you a problem in some way?

Thanks,
Matt

Comment 2 Michel Alexandre Salim 2008-07-06 05:12:28 UTC
Ah, thanks for the clarification. This should perhaps be noted in README.Fedora,
otherwise the user would take the information in the dkms manpage to be
authoritative.

Comment 3 Matt Domsch 2009-04-15 20:41:56 UTC
http://lists.us.dell.com/pipermail/dkms-devel/2009-April/000874.html
includes a patch for the manpage.  I'm going to mark this as closed now.

Thanks,
Matt