Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453366

Summary: X locks on boot with 82G33/G31 Express Integrated Graphics Controller
Product: [Fedora] Fedora Reporter: Chris Sorisio <chris.sorisio>
Component: xorg-x11-drv-i810Assignee: Adam Jackson <ajax>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 9CC: holger.lubitz, mcepl, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-09-02 12:19:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
xorg log for failed boot attempt
none
lspci output
none
Xorg log for failed boot attempt using xorg-x11-drv-i810-2.3.2-2.fc9.x86_64 none

Description Chris Sorisio 2008-06-30 06:09:17 UTC
I performed a fresh install of Fedora 9.  System booted to user final steps
menu, but screen locked when X booted for user logon.

I have to boot in text mode and run startx manually.

System worked fine under Fedora 8.  lspci and xorg output attached.

Comment 1 Chris Sorisio 2008-06-30 06:09:17 UTC
Created attachment 310562 [details]
xorg log for failed boot attempt

Comment 2 Chris Sorisio 2008-06-30 06:10:28 UTC
Created attachment 310563 [details]
lspci output

Comment 3 Matěj Cepl 2008-06-30 19:00:18 UTC
Lovely crash in
/usr/lib64/xorg/modules/drivers//intel_master_drv.so(I830WaitLpRing+0x1c1) 

Comment 4 Chris Sorisio 2008-07-03 01:32:04 UTC
Created attachment 310872 [details]
Xorg log for failed boot attempt using xorg-x11-drv-i810-2.3.2-2.fc9.x86_64

Comment 5 Chris Sorisio 2008-07-03 01:33:01 UTC
I updated to xorg-x11-drv-i810-2.3.2-2.fc9.x86_64 to see if that would resolve
my issue.  X no longer failed silently, but instead displayed smeared screen,
then reset, smeared screen, reset, repeat.  If I boot into run mode 3 and
startx, it works fine.  Latest xorg log attached.

Comment 6 Chris Sorisio 2008-07-03 03:07:06 UTC
This bug may be a dupe of 446620.  Booting without rhgb gets me into runlevel 5
as expected, and it leaves the video memory uncached.

Comment 7 Chris Sorisio 2008-08-01 21:39:50 UTC
Could this be related to the Foxconn/AMI BIOS issues?

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/251338

Comment 8 Matěj Cepl 2008-09-02 12:19:51 UTC
(In reply to comment #6)
> This bug may be a dupe of 446620.  Booting without rhgb gets me into runlevel 5
> as expected, and it leaves the video memory uncached.

You are probably right. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 446620 ***