Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453365

Summary: patch-2.5.4-34.fc9.x86_64 doesn't ignore selinux when it is disabled
Product: [Fedora] Fedora Reporter: H.J. Lu <hongjiu.lu>
Component: patchAssignee: Tim Waugh <twaugh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: rc040203
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 2.5.4-35.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-09 02:50:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 165799    

Description H.J. Lu 2008-06-30 06:00:25 UTC
I disabled selinux before creating a few files with
security context. patch-2.5.4-34.fc9.x86_64 failed
with

patch: **** Can't set security context on file
gcc/testsuite/g++.dg/abi/mangle24.C : Operation not permitted

when it tries to patch the file when it was created
with security context. The previous patch works fine.
Why can't patch create a new file without security
context when selinux is disabled?

Comment 1 Tim Waugh 2008-06-30 09:46:41 UTC
*** Bug 453383 has been marked as a duplicate of this bug. ***

Comment 2 Tim Waugh 2008-06-30 09:56:56 UTC
Hmm, the man page says that we're meant to get ENOTSUP in that situation, but
instead we're getting EPERM.  OK, will work around.

Comment 3 Fedora Update System 2008-06-30 12:22:09 UTC
patch-2.5.4-35.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-07-01 05:28:41 UTC
patch-2.5.4-35.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update patch'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5894

Comment 5 Tim Waugh 2008-07-07 12:08:39 UTC
Has anyone tried this test update?

Comment 6 Ralf Corsepius 2008-07-07 12:36:52 UTC
(In reply to comment #5)
> Has anyone tried this test update?
Yes,  I am using a locally built rpm I rebuilt from your sources to address
https://bugzilla.redhat.com/show_bug.cgi?id=453365.

I haven't checked the details of your patch, but it at least got me going again.


Comment 7 Fedora Update System 2008-07-09 02:50:31 UTC
patch-2.5.4-35.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.