Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453299

Summary: CastPodder will not load, it will crash after the splash screen
Product: [Fedora] Fedora Reporter: Knut J BJuland <knutjbj>
Component: CastPodderAssignee: Paul F. Johnson <paul>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: 10CC: awilliam, bugs.michael, ewinb, lex.lists
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-11-18 23:34:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Knut J BJuland 2008-06-29 09:07:00 UTC
Description of problem: CastPodder will not load, it starts up with the splash 
screen but then crashes.  This appears to be an incompatibility with 

Version-Release number of selected component (if applicable): 5.0-8

How reproducible:  start CastPodder from a command line and it will then load 
with the splash/title screen but then crashes.

Steps to Reproduce:
1. yum install CastPodder
2. start CastPodder from a command
Actual results:  CastPodder crashes with the following error: DeprecationWarning: The wxPython compatibility package is 
no longer automatically generated or actively maintained.  Please switch to 
the wx package as soon as possible.
  from   wxPython.wx import *
[<class 'ipodder.players.XMMSPlayer'>, <class 'ipodder.players.NoPlayer'>]
Beep-Media-Player couldn't be imported
Traceback (most recent call last):
  File "", line 3623, in <module>
  File "", line 3617, in main
    myApp = iPodderGui(ipodder)
  File "", line 685, in __init__
    wx.App.__init__(self, False, None)
  File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/", 
line 7757, in __init__
  File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/", 
line 7354, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "", line 1519, in OnInit
  File "", line 1876, in InitHooks
    for att, method in inspect.getmembers(self, inspect.ismethod):
  File "/usr/lib/python2.5/", line 206, in getmembers
    value = getattr(object, key)
  File "/usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/", 
line 9319, in GetAcceleratorTable
    return _core_.Window_GetAcceleratorTable(*args, **kwargs)
TypeError: in method 'Window_GetAcceleratorTable', expected argument 1 of 
type 'wxWindow *' 

Expected results:  CastPodder should start and run

Additional info:  Installing the compatibility packages for wxPython and wxGTK 
does not resolve the issue.  I've also seen this happen with the icepodder 
package which is the successor to CastPodder

The fix is in fact rather simple:

CastPodder / IcePodder use wxversion.ensureMinimal('2.6') to require wxGTK 2.6
at minimum. Since they don't work with 2.8, all you have to do is change it to'2.6') , to use *only* version 2.6. And obviously, you need
packages of wxGTK 2.6 that are parallel installable with your 2.8 packages. :)
We have this setup in Mandriva, you guys can grab our specs if you need to, of

Comment 1 Ewin Barnett 2008-12-30 04:05:57 UTC
Could someone touch this?  Of all the media aggregaters available for Fedora, this is the only one (it seams) that will download the podcasts on a daily schedule, keep them segregated in discrete directories and retain their original file names.  This makes it a simple matter to decide which ones to drop and drag into my personal portable MP3 player.   It also makes it easy when I want to refer a friend to a great podcast they might want to download for themselves, for CastPodder retains the original download link.  

The above "rather simple" repair link is now broken.  When I did install wxGTK 2.6, it failed on three dependencies, none of which appear to be clean Fedora rpms.  So, I stopped there.  I have a Windoze version of CastPodder running and I'll keep it going until the Fedora version gets fixed.

Comment 2 lexual 2009-02-24 22:23:13 UTC
Reproduced on Fedora 10.

Comment 3 Ewin Barnett 2009-04-12 18:38:34 UTC
I just installed Fedora 11 Beta, ran yum update to bring the system to the current level of fixes, used Yumex to install CastPodder and it still blows up.

Here is the console log:

[eb@localhost ~]$ uname -a
Linux localhost.localdomain #1 SMP Tue Apr 7 05:04:51 EDT 2009 i686 i686 i386 GNU/Linux

[eb@localhost ~]$ CastPodder DeprecationWarning: The wxPython compatibility package is no longer automatically generated or actively maintained.  Please switch to the wx package as soon as possible.
  from   wxPython.wx import *
/usr/share/CastPodder/ipodder/ DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  from   sha import *
[<class 'ipodder.players.XMMSPlayer'>, <class 'ipodder.players.NoPlayer'>]
Beep-Media-Player couldn't be imported
/usr/share/CastPodder/ipodder/ DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import logging,md5,time,os,threading,time
Traceback (most recent call last):
  File "", line 3700, in <module>
  File "", line 3691, in main
    ipodder = core.iPodder(config,state)
  File "/usr/share/CastPodder/ipodder/", line 1144, in __init__
    self.feeds = feeds.Feeds(self.config, self.state)
  File "/usr/share/CastPodder/ipodder/", line 334, in __init__
  File "/usr/share/CastPodder/ipodder/", line 763, in clean_state_database
    for key in state.iterkeys(): 
  File "/usr/share/CastPodder/ipodder/", line 227, in iterkeys
    return self.__shelf.iterkeys()
  File "/usr/lib/python2.6/", line 337, in iterkeys
    return iter(self)
  File "/usr/lib/python2.6/bsddb/", line 167, in __iter__
    return self.db.__iter__()
AttributeError: 'DB' object has no attribute '__iter__'
[eb@localhost ~]$

Comment 4 Michael Schwendt 2009-05-22 14:06:54 UTC
This has been left unanswered since Fedora 7 and bug 246405. It would be better to retire this package instead of offering completely non-working software.


CastPodder has been put to bed, RIP.

After 3 years of coding and its predecessor iPodder being sued by Apple, ripped by PodNova and now the code being miss-handled by distribution packages I have discontinued its development. The majority bitching that I turned it into a commercial product and the rest just plain bitching.

Well I have had enough. Support is now over, coding is stopped and all dns has been removed for the domain name.

Thanks to all that supported and donated to the project.

CastPodder died on Nov. 8, 2006 - RIP 


If I understand Adam Williamson correctly, a compat-wxPython-GTK26 package for our compat-wxGTK26 would have been needed (or porting to wxPython 2.8)

> Comment 3 by Ewin Barnett

Looks like a different problem.

Comment 5 Adam Williamson 2009-05-22 19:19:04 UTC
yep, indeed, IIRC that is the case. I believe I dropped the package from Mandriva as part of my work to migrate it entirely to wx* 2.8 and drop earlier versions of the wx stuff.

Comment 6 Adam Williamson 2009-05-22 19:22:22 UTC
oh, wait, I'm on crack. icepodder succeeded castpodder. Last time I touched this stuff was December 2008:

at that point, SVN icepodder worked with wx* 2.8, and worked in development Mandriva (I would have tested before uploading it). So we may have a reasonable chance of success introducing icepodder as a new package to obsolete castpodder, and using the latest SVN code for it.

Comment 7 Michael Schwendt 2009-05-23 07:08:55 UTC
The request to block this package:

Comment 8 Bug Zapper 2009-11-18 09:36:26 UTC
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here:

Comment 9 Adam Williamson 2009-11-18 23:34:23 UTC
package was blocked.

Fedora Bugzappers volunteer triage team