Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453238

Summary: In fedora i can not remove dead dependencies
Product: [Fedora] Fedora Reporter: Cepreu <cepreu.mail>
Component: yumAssignee: Seth Vidal <skvidal>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: ffesti, james.antill, jhutar, katzj, pmatilai, tla
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-22 22:41:54 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Cepreu 2008-06-28 04:31:40 UTC
Description of problem:
If i install big package with many dependencies and than remove it with yum, all
of it dependencies stay installed in system. Also, if i have big package
installed on livecd, which i download from fedoraproject.org/get-fedora (my
situation), i cannot use yum.log to delete this dependencies. bu i do not want
to turn my system in trash and also do not have time to analyze all 1000
installed packages in my system. In debian this problem was solved by programs like 
"debfoster". In fedora i can not find analog.

Comment 1 James Antill 2008-06-28 14:09:04 UTC
 You can try looking at the output of:

     package-cleanup --leaves --exclude-bin --exclude-devel


...etc. (see the man page for package-cleanup and the --leaves option). We hope
to have a more automated/usable solution for Fed-11.


Comment 2 Cepreu 2008-06-29 03:02:42 UTC
Big thanks. It is great utility! I write about it in our fedoraforum:
www.fedoralinux.ru for people like me. Because it is too hard find it in google
(my experience), if you do not know, what to find.

Comment 3 Jan Hutaƙ 2008-07-08 08:59:37 UTC
So according to the comment #2 I think we can CLOSE this bug.

Comment 4 Cepreu 2008-07-22 22:07:56 UTC
Yes, i agree.