Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453202

Summary: localized Arabic installation crashs, so do a later call to s-c-date
Product: [Fedora] Fedora Reporter: Muayyad Alsadi <alsadi>
Component: system-config-dateAssignee: Nils Philippsen <nphilipp>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.9.32-1.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-09 02:40:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
a "patch -p1" to the ar.po file none

Description Muayyad Alsadi 2008-06-27 19:25:01 UTC
Description of problem:
bad translation case s-c-date to crash firstboot
and later call to system-config-date won't work

Version-Release number of selected component (if applicable):
system-config-date-1.9.30

How reproducible:
always

Steps to Reproduce:
instead of making a new installation
one can try this

LC_ALL=ar_JO.UTF-8 system-config-date
  
Actual results:
works but the terminal says

Couldn't split timezone name fields:
Untranslated TZ: Africa/Blantyre
Translated TZ:بلانتير


Expected results:
no error

Additional info:
to automatically detect such problem in other translations use the following
python one-linear

cd system-config-date-1.9.30/po/timezones
for i in *.po; do echo "****** testing $i:"; python -c 'import re,sys;
s=sys.stdin.read(); print re.findall(r"^msgid[^/]*/.*\n(msgstr[^/]*)$",s,re.M)'
< $i; done | less

the expected output should be an empty set []

Comment 1 Muayyad Alsadi 2008-06-27 19:25:01 UTC
Created attachment 310470 [details]
a "patch -p1" to the ar.po file

Comment 2 Fedora Update System 2008-07-01 09:48:42 UTC
system-config-date-1.9.32-1.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-07-01 09:53:37 UTC
system-config-date-1.9.32-1.fc8 has been submitted as an update for Fedora 8

Comment 4 Nils Philippsen 2008-07-01 09:54:39 UTC
I've applied your patch in system-config-date-1.9.32-1.fc9 which should hit
updates-testing soon. Please check whether this fixes the problem.

Comment 5 Muayyad Alsadi 2008-07-01 12:25:37 UTC
and it worked as expected
it must work because I test it before submitting the patch, 
anyway, I get it from here 
http://kojipkgs.fedoraproject.org/packages/system-config-date/1.9.32/1.fc9/noarch/
and I test it again, and it worked, thanks



Comment 6 Nils Philippsen 2008-07-01 14:43:19 UTC
(In reply to comment #5)
> and it worked as expected
> it must work because I test it before submitting the patch, 

Hey, I could always have messed up integrating it or building the package ;-).

Comment 7 Muayyad Alsadi 2008-07-01 14:50:26 UTC
> Hey, I could always have messed up integrating it or building the package ;-).

that's why I said I did test it again.
because (you know) we should do that for QA or Murphy's laws will hunt us.



Comment 8 Fedora Update System 2008-07-02 06:31:54 UTC
system-config-date-1.9.32-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-date'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5927

Comment 9 Fedora Update System 2008-07-09 02:40:49 UTC
system-config-date-1.9.32-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2008-07-09 02:42:30 UTC
system-config-date-1.9.32-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.