Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 453116

Summary: perl-Time-Duration not built for perl 5.10.0
Product: [Fedora] Fedora Reporter: Paul Howarth <paul>
Component: perl-Time-DurationAssignee: Marc Bradshaw <fedora>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.06-4 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-04 00:14:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 454257    
Attachments:
Description Flags
Patch to add perl(:MODULE_COMPAT... dependency none

Description Paul Howarth 2008-06-27 12:01:32 UTC
The F-9 package of perl-Time-Duration has modules in "perl 5.8.8" paths,
which are not found by F-9's perl 5.10.0. The package therefore needs rebuilding
for perl 5.10.0.

There was a mass rebuild of perl packages late in the F-9 development period but
this package missed out on it, possibly because it is missing a perl version
"module compat" dependency and hence didn't have broken deps when perl was
upgraded to 5.10.0.

Comment 1 Paul Howarth 2008-06-27 12:01:32 UTC
Created attachment 310427 [details]
Patch to add perl(:MODULE_COMPAT... dependency

Comment 2 Fedora Update System 2008-06-29 11:07:54 UTC
perl-Time-Duration-1.06-2.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-06-29 11:38:18 UTC
perl-Time-Duration-1.06-4.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-06-29 22:00:55 UTC
perl-Time-Duration-1.06-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-Time-Duration'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5846

Comment 5 Fedora Update System 2008-07-02 06:32:35 UTC
perl-Time-Duration-1.06-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.