Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452906

Summary: abiword segfault
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: abiwordAssignee: Marc Maurer <uwog>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-25 20:13:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rex Dieter 2008-06-25 19:37:09 UTC
Fresh F-8 box, updates-testing enabled.

$ yum istall abiword
...
Installed: abiword.i386 1:2.4.6-6.fc8
Dependency Installed: gtkmathview.i386 0:0.7.6-5.fc6 link-grammar.i386
0:4.2.5-1.fc8 ots-libs.i386 0:0.4.2-11.fc7

$ abiword
Segmentation fault

$ gdb /usr/bin/abiword
...
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1209194176 (LWP 17569)]
0x0091cdf0 in ?? () from /usr/lib/libfontconfig.so.1
(gdb)
(gdb) backtrace
#0  0x0091cdf0 in ?? () from /usr/lib/libfontconfig.so.1
#1  0x00914f4f in ?? () from /usr/lib/libfontconfig.so.1
#2  0x0091822a in ?? () from /usr/lib/libfontconfig.so.1
#3  0x00918d0a in ?? () from /usr/lib/libfontconfig.so.1
#4  0x00918d89 in FcNameUnparse () from /usr/lib/libfontconfig.so.1
#5  0x08241684 in XAP_UnixFontManager::scavengeFonts ()
#6  0x082418bb in XAP_UnixFontManager::XAP_UnixFontManager ()
#7  0x0823c992 in XAP_UnixApp::_loadFonts ()
#8  0x0823cb02 in XAP_UnixApp::initialize ()
#9  0x08147ea1 in AP_App::initialize ()
#10 0x081410de in AP_UnixApp::initialize ()
#11 0x08142820 in AP_UnixApp::main ()
#12 0x0813ea4a in main ()

could install debuginfo and retry if desired.

Comment 1 Rex Dieter 2008-06-25 20:13:30 UTC

*** This bug has been marked as a duplicate of 448711 ***