Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452766

Summary: HAL daemon fails to start at boot
Product: [Fedora] Fedora Reporter: Sean A. Fulop <sfulop>
Component: halAssignee: David Zeuthen <davidz>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: mclasen, sonarguy
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-04-11 00:08:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sean A. Fulop 2008-06-24 22:19:34 UTC
Description of problem:
New Fedora 9 install, upgrade from Core 6
HAL daemon start fails during boot
HAL can be manually started using the Gnome Services tool

Version-Release number of selected component (if applicable):
Latest as of 6/23/2008

How reproducible:
Reboot machine; fails every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
HAL fails to start during boot, but can be manually started later

Expected results:
I expect HAL to start during boot like it's supposed to.

Additional info:

Comment 1 Sean A. Fulop 2008-06-27 06:56:24 UTC
The problem stems from messagebus appearing after hald in /etc/rc.5 (thanks to
BeLinux posting on Fedoraforums).

The workaround is to rename the symbolic link for messagebus so it appears above
the link for hald.

I don't know why some newly installed systems, like mine, would end up with
messagebus and hald in the wrong order in /etc/rc.5, but I think this makes this
a genuine bug in Fedora 9.



Comment 2 Scott Glaser 2009-04-10 22:37:54 UTC
Sean,
Are you still running Fedora 9, or have you upgraded to 10 or Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Sean A. Fulop 2009-04-10 23:34:28 UTC
Hi,

I'm still using Fedora 9, and I fixed the problem a long time ago as I described in the note, by manually changing etc/rc.5.  I don't know whether the new upgrades or installs will fix the problem, but at least I know how to manually fix it when I upgrade.

Comment 4 Scott Glaser 2009-04-11 00:08:49 UTC
Sean,
Thanks for your prompt response, from what I suspect this is an issue caused by upgrading from FC6 to F9.  On my F9 system they are in the correct order as listed below:

S05akmods
S06cpuspeed
S08ip6tables
S08iptables
S08nvidia
S09isdn
S11auditd
S12restorecond
S12rsyslog
S13irqbalance
S13rpcbind
S14nfslock
S15mdmonitor
S18rpcidmapd
S19rpcgssd
S22messagebus
S25fuse
S25netfs
S25pcscd
S26acpid
S26haldaemon
S26udev-post
S27NetworkManager
S28setroubleshoot
S50bluetooth
S55sshd
S58ntpd
S80sendmail
S90crond
S90kerneloops
S90smolt
S95atd
S96avahi-daemon
S98cups
S98wine
S99anacron
S99local

As you can see messagebus is started before haldaemon, this system was a clean install of F9 not an upgrade.  I do not have a copy of Fedora Core 6 to try an upgrade with so I am going to close this bug.  If you should experience this issue again with a future release please open a new bug against the current version of the component.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers