Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452764

Summary: evolution hangs when fetching email
Product: [Fedora] Fedora Reporter: Jon Burgess <jburgess777>
Component: evolutionAssignee: Matthew Barnes <mbarnes>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: mcrha
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-26 19:14:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
gdb backtrace for evolution show it waiting for the reply from gnome-settings-daemon none

Description Jon Burgess 2008-06-24 21:19:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061712 Fedora/3.0-1.fc9 Firefox/3.0

Description of problem:
Since I upgraded to F9 evolution has been hanging once or twice a week. When this occurs the window does not repaint and ignores any mouse/keyboard input.


Version-Release number of selected component (if applicable):
evolution-2.22.2-2.fc9.x86_64

How reproducible:
Sometimes


Steps to Reproduce:
1. Configure evo to fetch mail from multiple pop3 servers (of varying reliability)
2. Leave evo running 24/7 fetching mail every 15 minutes.

Actual Results:
Every few days evolution will lockup

Expected Results:


Additional info:
It looks like it the problem may be a bad interaction with gnome-keyring-daemon. I'll attach some backtraces which appear to show that evo was stuck fetching data from the keyring unix socket. 

I should mention that I'm a KDE4 user. I don't normally run the gnome-settings-daemon, might this help things?

I didn't get much else out of GDB so I decided to detach and kill the gnome-keyring-daemon. Evolution came back to life and prompted me to confirm the password for one of the pop3 servers. The keyring daemon even got respawned and was prompting me to allow access by evolution. 

This failure path of getting an error from the server even with the correct password seems to occur every few days, It has been happening for the past few years that I've been using Evo, I've always assumed that it was probably due to a transient issue on the server.

Comment 1 Jon Burgess 2008-06-24 21:32:16 UTC
Created attachment 310192 [details]
gdb backtrace for evolution show it waiting for the reply from gnome-settings-daemon

I suppose this could be a gnome-keyring-daemon issue but I'm sure you can
re-assign if you think this is the case.

There were no pop-up on the screen asking for me to enter any details at the
time of the hang. I made sure to minimised all the open windows just in case a
window was hiding behind something.

Comment 2 Matthew Barnes 2008-06-26 19:14:08 UTC
This same issue has been reported upstream, so I'm closing this with a reference
to the upstream bug where you can monitor the investigation.  Please see [1] for
further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=539210