Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452745

Summary: I can't uninstall "old" kernel images
Product: [Fedora] Fedora Reporter: Spider <spider>
Component: PackageKitAssignee: Robin Norwood <robin.norwood>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: lmacken, richard
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-04 10:04:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Spider 2008-06-24 19:17:52 UTC
Description of problem:
My "recent" Fedora 9 install has a few old kernel images in the Grub menu (which
I have to page through each boot due to dual-booting) and I cannot remove them
with PackageKit as it is shipped with Fedora 9

Version-Release number of selected component (if applicable):


How reproducible:
Install and update

Steps to Reproduce:
1. Open "add remove software"  
2. Search for "kernel"  
3. select one of the many versions installed and try to uninstall it.
4. Miserable failure, claims it wants to remove half your system.

Actual results:


Expected results:
Removing old unneeded packages.

Additional info:
Hopefully fixed already, but fix is not propagated to default system.

Comment 1 Richard Hughes 2008-06-25 14:10:20 UTC
Yup, already fixed in master, I just need to push a new major version into F9.