Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452648

Summary: inkscape doesn't load svg file.
Product: [Fedora] Fedora Reporter: sangu <sangu.fedora>
Component: inkscapeAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: low    
Version: rawhideCC: lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-20 10:31:18 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description sangu 2008-06-24 09:47:38 UTC
Description of problem:
inkscape doen't load svg file.

** (inkscape:24825): CRITICAL **: Inkscape::XML::Document*
sp_repr_read_file(const gchar*, const gchar*): assertion
`Inkscape::IO::file_test( filename, G_FILE_TEST_EXISTS )' faile

Version-Release number of selected component (if applicable):
0.46-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. launch inkscape
2. open dialog ( ctrl + o)
3. select svg file
  
Actual results:


Expected results:


Additional info:
$ inkscape /usr/share/icons/gnome/scalable/apps/text-editor.svg works well.
gtkmm24-2.13.0-1.fc10.i386
glibmm24-2.16.2-1.fc10.i386

Comment 1 Lubomir Rintel 2008-06-24 11:29:57 UTC
Thanks for the report;

I don't have a Rawhide machine handy, so it may take a couple of days until I am
able to reproduce it. But it may be today as well :)

Comment 2 Lubomir Rintel 2008-06-24 12:54:21 UTC
Oh, well, I can use mock too..

Comment 3 Lubomir Rintel 2008-06-25 20:47:07 UTC
#0  IA__g_logv (log_domain=0x624cbc "GLib-GObject", log_level=G_LOG_LEVEL_CRITICAL, 
    format=0x71227f "%s: assertion `%s' failed", args1=0xbfffae5c "´┐Żeb") at
gmessages.c:503
#1  0x006bcf36 in IA__g_log (log_domain=0x624cbc "GLib-GObject",
log_level=G_LOG_LEVEL_CRITICAL, 
    format=0x71227f "%s: assertion `%s' failed") at gmessages.c:517
#2  0x006bd19b in IA__g_return_if_fail_warning (log_domain=0x624cbc "GLib-GObject", 
    pretty_function=0x6265f0 "g_object_ref", expression=0x625892 "G_IS_OBJECT
(object)") at gmessages.c:532
#3  0x005fe19b in IA__g_object_ref (_object=0x0) at gobject.c:1719
#4  0x00f893d5 in gtk_file_chooser_default_get_current_folder
(chooser=0x96e01c0) at gtkfilechooserdefault.c:7056
#5  0x00f72f92 in _gtk_file_chooser_get_current_folder_file (chooser=0x96e01c0)
at gtkfilechooser.c:1046
#6  0x00f97925 in delegate_get_current_folder (chooser=0x92ce918) at
gtkfilechooserutils.c:303
#7  0x00f72f92 in _gtk_file_chooser_get_current_folder_file (chooser=0x92ce918)
at gtkfilechooser.c:1046
#8  0x00f97925 in delegate_get_current_folder (chooser=0x9467910) at
gtkfilechooserutils.c:303
#9  0x00f72f92 in _gtk_file_chooser_get_current_folder_file (chooser=0x9467910)
at gtkfilechooser.c:1046
#10 0x00f724d9 in IA__gtk_file_chooser_get_current_folder (chooser=0x9467910) at
gtkfilechooser.c:691
#11 0x003717b0 in Gtk::FileChooser::get_current_folder (this=0xaa1c73c) at
filechooser.cc:376
#12 0x081e8144 in Inkscape::UI::Dialog::FileOpenDialogImplGtk::show (this=0xaa1c728)
    at ui/dialog/filedialogimpl-gtkmm.cpp:811

Comment 4 Lubomir Rintel 2008-06-25 21:38:09 UTC
bool

FileOpenDialogImplGtk::show()

{

    Glib::ustring s = Glib::filename_to_utf8 (get_current_folder());

    if (s.length() == 0)

        s = getcwd (NULL, 0);

    set_current_folder(Glib::filename_from_utf8(s)); //hack to force initial dir
listing

    set_modal (TRUE);                      //Window

    sp_transientize((GtkWidget *)gobj());  //Make transient

    gint b = run();                        //Dialog

    svgPreview.showNoPreview();

    hide();


get_current_folder() and set_current_folder() use GFile instead of GtkFilePath
since this commit [1], so the above won't work.

[1] http://mail.gnome.org/archives/svn-commits-list/2008-June/msg02000.html

Comment 5 Lubomir Rintel 2008-06-26 06:48:20 UTC
Seems like the lines are gone from upstream's SVN too.

Comment 6 Lubomir Rintel 2008-06-26 08:37:00 UTC
Wheee, I think I found it. gtk2-2.13.3-3.fc10 should fix it.

You may also want to grab inkscape-0.46-3.fc10, just to prevent some useless
assertion fails.

Both are being built now.