Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452589

Summary: selinux-polgengui doesn't open when launched from the menu
Product: [Fedora] Fedora Reporter: Peeter Puusemp <peeter.as>
Component: policycoreutilsAssignee: Daniel Walsh <dwalsh>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: nalin
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-18 03:07:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Peeter Puusemp 2008-06-23 22:14:49 UTC
Description of problem:
SELinux Policy Generation Tool doesn't open when launched from the menu. It
opens it only for a (milli)second.

If to open it from the terminal, it opens up and doesn't disappeear. Terminal
output:

# selinux-polgengui 
WARNING: Policy would be downgraded from version 23 to 22.
WARNING: Policy would be downgraded from version 23 to 22.
WARNING: Policy would be downgraded from version 23 to 22.

I have fully updated system. I am not the only one who has this problem:
http://www.fedoraforum.org/forum/showthread.php?t=191716

Version-Release number of selected component (if applicable):
policycoreutils-2.0.49-3.fc9.src.rpm

How reproducible:
Open SELinux Policy Generation Tool from the menu.

Comment 1 Daniel Walsh 2008-06-24 09:50:49 UTC
Nalin, 

Any ideas on how to debug this?

Comment 2 Peeter Puusemp 2008-08-18 03:07:49 UTC
I was away from the computer for some time. Now, after installing all available updates for Fedora, it works.

So +1 closed bug. :)