Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 452359

Summary: clamav-milter posts negative pid
Product: [Fedora] Fedora Reporter: Vadym Chepkov <vchepkov>
Component: clamavAssignee: Enrico Scholz <rh-bugzilla>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: steve
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 0.93.3-1.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-07-17 14:15:34 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vadym Chepkov 2008-06-21 11:52:34 UTC
Description of problem:
clamav-milter posts a negative pid in the pid file, init script fails to 
shutdown the daemon.

Version-Release number of selected component (if applicable):

clamav-milter-core-0.93.1-1.fc9.i386
clamav-milter-sysv-0.93.1-1.fc9.i386

How reproducible:

'service clamav-milter stop' fails

Comment 1 Vadym Chepkov 2008-07-13 17:05:52 UTC
I examined this more closely and find out that init script tries to cope with
this by adding sed -i -e 's/-//' $pidfile command after the milter's start. The
problem is it can (and it does) reach this before milter created the pid file
and pid stays negative. The proper solution, I would think, should be to modify
killproc function to handle negative pids, but as a workaround the sed command
could be added before call to killproc.
 

Comment 2 Fedora Update System 2008-07-13 19:46:12 UTC
clamav-0.93.3-1.fc9 has been submitted as an update for Fedora 9

Comment 3 Fedora Update System 2008-07-15 12:13:12 UTC
clamav-0.93.3-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update clamav'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6338

Comment 4 Fedora Update System 2008-07-17 14:15:29 UTC
clamav-0.93.3-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Vadym Chepkov 2008-07-17 18:14:41 UTC
For some reasons /etc/rc.d/init.d/clamav-milter is marked as a config file in 
clamav-milter-sysv, so I had to manually remove my "patch". sed command call in 
this script is also redundant, since bug was fixed.