Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 451760

Summary: Qt combo boxes have wrong window type
Product: [Fedora] Fedora Reporter: Danny Baumann <dannybaumann>
Component: qtAssignee: Ngo Than <than>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: kevin, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: qt-4.3.5-2.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-18 13:23:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Danny Baumann 2008-06-17 07:56:20 UTC
Description of problem:
Qt's combo boxes don't set the _NET_WM_WINDOW_TYPE_COMBO type hint, but set the
NORMAL type hint instead. This causes those combo boxes to be incorrectly
animated in compositing managers.

Version-Release number of selected component (if applicable):
4.3.5-1.fc9

How reproducible:
Always

Steps to Reproduce:
1. Open qtconfig-qt4
2. Open the "Select GUI style" combo box
3. Watch it being animated as a normal window
  
Additional info:
The problem is solved in the qt-4.3.5-2.fc9 package available on koji.

Comment 1 Fedora Update System 2008-06-18 03:37:11 UTC
qt-4.3.5-2.fc9 has been submitted as an update for Fedora 9

Comment 2 Fedora Update System 2008-06-20 19:15:27 UTC
qt-4.3.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 3 Fedora Update System 2008-07-26 06:08:14 UTC
qt-4.3.5-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.