Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 451711

Summary: F8/9 bootline parameter "ip=" has no effect, but other parameters work just fine.
Product: [Fedora] Fedora Reporter: Eliran Itzhak <eliranitzhak>
Component: anacondaAssignee: David Cantrell <dcantrell>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: gustavo
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-10-11 03:18:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 458183    
Bug Blocks:    
Attachments:
Description Flags
A screen capture taken in the F9 install process. It shows that all the parameters from the bootline works except the IP= parameter. none

Description Eliran Itzhak 2008-06-16 20:07:05 UTC
Description of problem:
Hello ! 
I suspect I found a bug in the F8/9 install process.
I gave the following command line at the bootline of the F9 installed (i386 DVD)

vnc ip=10.0.0.1 netmask=255.255.255.0 gateway=10.0.0.138 dns=10.0.0.138 noipv6

What I expected : The system should boot with the ip parameters given, ask a
couple of questions (language etc. but NOT ip related) then load the vnc server
and start anaconda. No questions about the ip address or other parameters should
be brought up.

What actually happends :
The system brings up a screen to configure the ip parameters, WITH all the
parameters I gave at the boot line, EXCEPT the ip address.

I tested this both with the F8 and the F9 installers, both on a regular machine
and then with Vmware too.

I also tested it with the Centos 5 Install DVD, where it works as expected, and
no IP questions are asked. (Sorry but centos 5 is the closest I have to RHEL)

Version-Release number of selected component (if applicable):
This (bug) was tested on F8 & F9

How reproducible:
Install from the F9 DVD image with the following cl.
vnc ip=10.0.0.1 netmask=255.255.255.0 gateway=10.0.0.138 dns=10.0.0.138 noipv6

Steps to Reproduce:
1.
2.
3.
  
Actual results:
A screen that asks for the ip address comes up.

Expected results:
A screen that asks for the ip address should NOT come up :-)

Additional info:
I've attached two screen captures that show the problem I'm reporting about.
As for the bootline parameters I was working with the following document that
lists them.
The document is at https://publictest1.fedoraproject.org/wiki/Anaconda/Options

Comment 1 Eliran Itzhak 2008-06-16 20:07:05 UTC
Created attachment 309530 [details]
A screen capture taken in the F9 install process. It shows that all the parameters from the bootline works except the IP= parameter.

Comment 2 Gustavo Maciel Dias Vieira 2008-07-23 21:28:23 UTC
I'm seeing this bug too, with the F9 installer on KVM. 

Per the report above I asume it won't work in a real box either. This is a real
pain for me, as I have a bunch of headless machines to install and no option to
use DHCP (DHCP works).


Comment 3 Gustavo Maciel Dias Vieira 2008-07-23 23:44:40 UTC
This bug is a duplicate of bug #392021

Comment 4 David Cantrell 2008-10-11 03:18:10 UTC
This is fixed in rawhide as of anaconda-11.4.1.48-1.