Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 451659

Summary: Gatekeeper Service Breach Time Calculation Does Not Account For Weekend
Product: [Retired] JBoss Customer Support Portal Reporter: Mike Millson <mmillson>
Component: GatekeeperAssignee: JBoss CSP Bug Watch List <csp-bugs-watch>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: high    
Version: 1.4CC: nlugert
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: MR8-CSP Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-30 19:51:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Mike Millson 2008-06-16 14:58:33 UTC
Description of problem:
GE case #157956 was commented on by customer 06-14-2008 08:13pm EDT. Gatekeeper
set Service Breach Time to 06-14-2008 10:13pm EDT. This is not correct, sev 2
cases are 4 _business_ hours[1]. It looks like Gatekeeper is not accounting for
weekends in this case.

[1]http://www.redhat.com/support/policy/sla/production/

Comment 1 Nathan Lugert 2009-02-09 17:55:45 UTC
Gatekeeper does account for weekends if the response time is in business hours. If group has a special SLA like "2 hours" then weekends are counted.