Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 451518

Summary: Labels /etc and /usr as user_home_dir_t
Product: [Fedora] Fedora Reporter: Enrico Scholz <rh-bugzilla>
Component: policycoreutilsAssignee: Daniel Walsh <dwalsh>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-16 11:08:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Enrico Scholz 2008-06-15 09:21:51 UTC
Description of problem:

Please provide a way to 

a) disable the user_home_dir_t magic completely (homedirs on my
   machines are either NFS mounted, or there are no homedirs at
   all), or

b) filter-out certain accounts; the current heuristic (/sbin/nologin
   shell or uid < 500) does not suffice.

I have several system-accounts which require a regular shell (e.g. because
they start jobs through ~/.ssh/authorized_keys). Currently, these accounts
are handled like normal users and filesystem is completely mislabeled
(e.g. /etc and /usr/share are user_home_dir_t).


Version-Release number of selected component (if applicable):

policycoreutils-2.0.47-2.fc9.x86_64

Comment 1 Daniel Walsh 2008-06-16 11:08:44 UTC
Add 
disable-genhomedircon = true

to /etc/selinux/semanage.conf