Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 451485

Summary: Cells text orientation with 90 degrees option
Product: [Fedora] Fedora Reporter: Maciej Kaczmarek <mkaczma>
Component: openoffice.orgAssignee: Caolan McNamara <caolanm>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: ahoffsta, jes, jnavrati
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.4.1-17.4.fc9 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-06-25 02:53:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Attachment is showing described problem. none

Description Maciej Kaczmarek 2008-06-14 19:03:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
When I change text orientation in cell, I do not get the proper orientation as expected. I checked that behaviour only with numbers. The option I was trying was 90 degrees.

Version-Release number of selected component (if applicable):
openoffice.org-calc-2.4.1-17.3.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1.Open openoffice.org calc and write numbers in cells
2.Choose Cells form menu Format and select Alignment tab
3.Change 0 to 90 Degrees in Text orientation
if numbers are showed as you expected, then
4. Change font for those cells

Actual Results:
When in cells are two numbers one is oriented 0 degrees while the other is oriented 90 degrees.

Expected Results:
Proper orientation numbers

Additional info:

Comment 1 Maciej Kaczmarek 2008-06-14 19:07:34 UTC
Created attachment 309366 [details]
Attachment is showing described problem.

Comment 2 Caolan McNamara 2008-06-15 09:57:46 UTC
does

export SAL_DISABLE_CAIROTEXT=1

make a difference ?

Comment 3 Maciej Kaczmarek 2008-06-15 13:00:10 UTC
(In reply to comment #2)
> does
> 
> export SAL_DISABLE_CAIROTEXT=1
> 
> make a difference ?

No, it does not.

Comment 4 Caolan McNamara 2008-06-15 20:32:03 UTC
Will be fixed in the next update, >= 2.4.1-17.4

Comment 5 Caolan McNamara 2008-06-16 07:49:49 UTC
*** Bug 451569 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2008-06-16 12:20:30 UTC
openoffice.org-2.4.1-17.4.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-06-16 23:33:02 UTC
openoffice.org-2.4.1-17.4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5386

Comment 8 Caolan McNamara 2008-06-22 20:33:16 UTC
*** Bug 452380 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2008-06-25 02:52:54 UTC
openoffice.org-2.4.1-17.4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.