Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 450999

Summary: missing header files
Product: [Fedora] Fedora Reporter: Terje Røsten <terjeros>
Component: blitzAssignee: Sergio Pascual <sergio.pasra>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 9CC: mvanross
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-12-18 18:03:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Terje Røsten 2008-06-12 08:52:27 UTC
Description of problem:

This change

* Sat Dec 22 2007 Sergio Pascual <sergiopr at fedoraproject.com> 0.9-4
- Arch dependent gnu/bzconfig.h moved to %%libdir/blitz/include/blitz/gnu

breaks as blitz/bzconfig is umodified:

#elif defined(__GNUC__)
/* GNU gcc compiler */
#include <blitz/gnu/bzconfig.h>

and /usr/include/blitz/gnu don't exists anymore.

Header files in %_lib seems broke too, see e.g. apr package 
(multilib apr.h hack) how to keep header in %_include:

http://cvs.fedoraproject.org/viewcvs/rpms/apr/devel/apr.spec?rev=1.75&view=markup

Comment 1 Sergio Pascual 2008-06-15 05:17:21 UTC
Well, what I did was to modify also blitz.pc so that 
$ pkg-config --cflags blitz 
-I/usr/lib64/blitz/include

If you compile your program with  
$  g++ myprogram.cc `pkg-config blitz --libs --cflags`
it should work

anyway I will look the apr example and look if it makes sense

Comment 2 Sergio Pascual 2008-11-13 01:28:24 UTC
I have submitted a bug upstream about this.

https://sourceforge.net/tracker/index.php?func=detail&aid=2273091&group_id=63961&atid=505791

Comment 3 Sergio Pascual 2008-12-27 15:58:06 UTC
*** Bug 478297 has been marked as a duplicate of this bug. ***