Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 45

Summary: Selecting multiple fields in a query form does not work
Product: [Community] Bugzilla Reporter: Aleksey Nogin <aleksey>
Component: Bugzilla GeneralAssignee: David Lawrence <dkl>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: high    
Version: 2.1rCC: astokes
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1998-11-12 19:15:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Attached file automatically from /tmp/makeinstall.txt. none

Description Aleksey Nogin 1998-11-11 19:55:58 UTC
When I select multiple fields in some entries (such as
"Status" or "Program") of the bug query form, only the bugs
that match the first selected entry are displayed, while
mozilla.org Bugzilla would display all bugs matching one of
the selected entries.

Comment 1 Need Real Name 1998-11-12 18:38:59 UTC
alas, tis true

Comment 2 Need Real Name 1998-11-12 19:15:59 UTC
ok, found this one, url_decode was getting called too soon causing
only the first option to be matched.  this actually fixes several
issues at once.

Comment 3 Adam Stokes 2010-03-08 17:14:36 UTC
Created attachment 398569 [details]
Attached file automatically from /tmp/makeinstall.txt.